Overview:
This article pertains to common license/licensing and licenses key errors in Private-Host and Cloud. If you cannot find the error that relates to you, you can always submit a ticket on our support site or send an email to support@solverglobal.com.
License Key Errors > Data Warehouse License Key
❌Product Not Licensed Exception:
When attempting to create an attribute, a dimension, or a module, the user runs into the following error:
Review this KB on how to utilize Dev Tools to determine more details if any within the error.
Cause
Though this error occurs within integrations, it is not necessarily related to integrations as the underlying issue.
This error is related to the Data Warehouse license Key - if dev tools hint at an issue with license expiration, verify that the Data Warehouse license key is in the database (within SQL SolverDW > Common.licenses).
Determine within the table whether or not the license is expired. If there are multiple entries in this table, delete them and re-add the one that you have on file through the frontend:
If the expiration date has not passed, update/re-add the DW license key through the frontend to correct the error; otherwise, if the expiration date for the DW license key has passed, please reach out to Support.
Resolution:
- Check Data Connection, make sure you have a connection set-up
- Re-enter your Data Warehouse license key (Private-Host Only)
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If step one or two does not resolve your issue, the Data Warehouse license key may have expired. (Please contact Solver Support).
❌"Error occurred saving changes:DataWarehouse"
When attempting to publish an integration, the following error occurs:
Resolution:
Follow the previous resolution as it is related.
❌Private Host: "License update failed"
When entering Data Warehouse license key into the portal, it gives the error, "license update failed".
Cause & Resolution
Data Warehouse database connection is not set up or set up as windows authentication.
Create a new Data Warehouse database connection under Get Data module from left navigation pane. If the Data Warehouse database connection is already there, then edit the connection and ensure it is set with SQL authentication. Retype the SQL authenticated username and password and save it again. Then go back and enter DW license key again.
Licensing Issues/Errors
❌Reporting Menu Disappears After License Expires
When a Cloud subscription is nearing expiration, administrators on both the Customer (formerly Company) & Tenant level will see a banner across the web portal interface noting how many days they have until the subscription and/or licenses expire. The warning banner will first appear within 60 days of the expiration date. The banner will change to red within 14 days of expiration.
Once the expiration date passes, the Cloud web portal will be inaccessible with the exception of Home, Process Manager, Data Warehouse, and Settings. The rest of the left pane menu modules (Reporting and/or Planning) will disappear.
When subscriptions/licenses are renewed, these licenses will be accessible again.
Generally speaking, once licenses have been updated, there is no setting to turn the tenant back to active - the license update will do that automatically. However, there have been instances where the update did not happen and the licenses had to be manually reinstated by our Licensing team. Clearing cache and using different web browsers may resolve.
NOTE: There has been an issue relating to caching where license expiration is not a factor, causing the left pane menu modules Reporting and Planning to disappear as a result. Often, this affects one or more users (but not all users at once). You should be able to resolve this by clearing cache and site data within your web browser.
Resolution:
- Clear your cache and this should resolve the issue if it is not related to license renewal. This should only be related to specific users and not all users.
- For any license updates not reflecting correctly, our March 2022 Cloud release introduced a feature to manually refresh the license from the customer administration page on Cloud
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- Navigate to Settings > Administration > select the Company on the left side > Licensing tab > Click Update Licenses link
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❌"You have more assignments than available in license" error upon login
When this error message appears on the user's login screen, this entails that the customer organization has more users assigned to a license than they own licenses.
NOTE: It is important if you have made any licensing changes to verify with our Accounting team (accounting@solverglobal.com) and make those changes accordingly within the Administration Settings > Licensing tab within the Cloud web portal.
Resolution:
To resolve this, the Customer Admin user must log in to the tenant and maneuver to the administration settings to make the adjustments within the licensing tab to correct the error as all other end-users will not be able to surpass this error on the login screen.
If you are unsure who your Customer Admin user is, please contact both Support & Licensing/Accounting to verify this information. If changes in licensing were made but the licenses were not modified within the licensing tab, our team will have to drop the license assignments to the users to reflect correct license count.
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