Summary:
This article troubleshoots an error that occurs re-importing a tree in which the codes do not exist on the respective dimension or formatting of your import file has removed leading or trailing zeros.
Article Sections:
Symptoms:
When a user imports a tree, they receive the following error message:
“Codes _____ are missing from the dimension Entity.”
The user gets this when exporting a tree already created in the portal. When the user makes any or no changes to the csv file, then saves and re-imports, this is when the error occurs.
Causes:
This can happen for a couple reasons but the general cause is that the code(s) on your tree import file do not exist in its respective dimension. Reasons for this include:
- The codes do not exist on the respective dimension.
- The formatting of your import file has removed leading or trailing zeros. Converting what was intended to be 0100 to 100 for example.
Resolution:
- Make sure that all codes on your tree import file exist in its respective dimension. This includes all levels of the tree, including rollup levels, which may be non-operational codes.
- Open the CSV file used in the integration, change the format to General and try the import process again.
Properties:
Cloud