Summary:
This article troubleshoots an issue with the Report Designer Add-in not loading after the installation.
Article sections
Symptoms:
When a user installs the Report Designer add-in, the Add-in does not load upon launching the Microsoft Excel application.
Causes:
If users install 5.2 Reporting with a 64-bit Excel 2016 after previously having a 32-bit instance of Excel on their machine, they may not see the Solver Reporting add-in and the OSR Function will not work. This is happening because the registry keys for these two are being created in the 32-bit locations rather than the 64-bit location.
Resolution:
There are two changes, shown below as Step 1 and 2, that need to be made to resolve this issue.
Note: Please ensure you make a backup of the Entire Registry before making these changes. Also, these registry changes need to be made by IT personnel who is familiar with Registry changes. If you are not familiar with these steps, please contact Solver Support.
Step 1
- Find the OneStop.ReportDesigner reg key that was located here:
"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Excel\Addins\OneStop.ReportDesigner" - Export that key to your desktop.
- Then edit the registry key in notepad by removing the Wow6432Node folder path so that it looks like this:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\AddIns\OneStop.ReportDesigner]
"Description"="Reporting - Budgeting - Analysis"
"LoadBehavior"=dword:00000003
"FriendlyName"="OSR Report Designer 5 32-bit"
"Manifest"="file://C:\\Program Files\\OneStop Reporting\\Report Designer\\ReportDesigner\\OneStop.ReportDesigner.vsto|vstolocal" - Save this file and then double click on it or right click Merge to add this key to the registry.
Step 2
In some cases, even when the add-in loads correctly within Excel, users experience a new issue in which unfamiliar syntax or #NAME errors on the Excel sheet are shown instead of user-friendly labels such as Account. They may also experience:
- Fields dragged into the Report displaying as #NAME
- Reports do not run
This is because the OSR Function is missing.
Please verify if the OSRFunction add-in is enabled by going to Excel File Options Add-in. Also please check the location of the mscoree.dll and ensure that it is located at
- C:\Windows\System32 for 64 bit
- C:\Windows\SysWOW64 for 32 bit computers.
The following are scenarios and what needs to be done in those scenarios:
- If the add-in is not available, please re-install the software.
- If the add-in is available but not enabled, please enabled it.
- If the add-in is available and enabled, please repair Office.
- Uninstall BI360 Reporting completely and then re-install from fresh. When doing the installation, verify the office bitness is correct.
- Once installed from fresh, if it still does not work then go to Registry at the following location.
- HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\InprocServer32
- Verify the Codebase path that it is pointing to the correct program files folder. If you have 32-bit office then it should point to program files (x86) and if it is 64 bit then it should point to programfiles.
- HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\InprocServer32
-
Verify that MS Office bitness is not conflicting with other MS Office components' bitness. For example, MS Office is 32-bit but there might be MS Access Runtime is 64-bit causing conflict which causes BI360 Reporting to see 64-bit during installation. The bitness can be verified by going to view installed updates under uninstall programs in the control panel. It will show which office component has what bitness.
This resolves the #NAME errors in your report if all dimensions and attributes are not loading in your reports.
In some cases, you may be required to apply modifications to the registry key:
1. Export the key Computer\HKEY_CLASSES_ROOT\WOW6432NODE\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460} to your desktop
2. Edit the registry key by deleting out all of the WOW6432Nodes and replacing SysWow64 (also could be Sys64) with system32. The registry key may not completely match but should look similar to what is listed below:
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}]
@="OneStop Reporting Functions"
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\Implemented Categories]
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\Implemented Categories\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}]
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\InprocServer32]
"Class"="OneStop.ReportPlayer.OSRFunctions"
"Assembly"="OneStop.OSRFunctions, Version=3.3.0.0, Culture=neutral, PublicKeyToken=null"
"CodeBase"="file:///C:\\Program Files\\OneStop Reporting\\Report Designer\\ReportDesigner\\OneStop.OSRFunctions.dll"
"RuntimeVersion"="v4.0.30319"
"ThreadingModel"="Both"
@="C:\\WINDOWS\\system32\\mscoree.dll"
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\InprocServer32\3.3.0.0]
"Class"="OneStop.ReportPlayer.OSRFunctions"
"Assembly"="OneStop.OSRFunctions, Version=3.3.0.0, Culture=neutral, PublicKeyToken=null"
"CodeBase"="file:///C:\\Program Files\\OneStop Reporting\\Report Designer\\ReportDesigner\\OneStop.OSRFunctions.dll"
"RuntimeVersion"="v4.0.30319"
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\ProgId]
@="OneStop.ReportPlayer.OSRFunctions"
[HKEY_CLASSES_ROOT\CLSID\{74B6B2D2-F28A-4F03-BB6A-6B5DA5306460}\Programmable]
3. Save to Desktop
4. Double-click to update the Registry
This change allows you to use OSR functions in Excel.
References
- How to enable add-ins in Excel
- How to repair office programs
- 4x Report Designer & Planning Excel Add-ins: Overview & Troubleshooting
Properties
Applies to:
- Solver Cloud
- Private Host
- BI360 - 4x