Summary
This article covers how to resolve an issue within Excel when a component of the Solver Add-in is not loading properly.
The steps documented in this KB article are applicable to Solver Cloud, Private Host 5x, and the BI360 4x application.
Article Sections:
Symptoms:
When a user opens a report, the fields that have been dragged into the report appear as #NAME. This excel error may also appear when you run the report and also returns no data.
Causes:
This is happening because a component of the Solver Add-in is not loading properly.
Resolution:
Before proceeding,
- Please note the version of the Excel Add-in you have installed. This can be found in the About menu within the Excel ribbon.
- Ensure you have the Report Designer installer. Please contact Solver Support if you do not have this installer.
Note: The steps documented in this article modify your Computer's registry. The registry is a sensitive component of you computer.
- Please review this article with your IT department.
- Please ensure to backup the Entire Registry before making these changes.
- These registry changes need to be made by IT personnel who is familiar with Registry changes. If you are not familiar with these steps, please contact Solver Support.
Step 1:
Perform a reinstall of the application. Steps to reinstall the Report Designer can be found here.
Step 2:
If the reinstall does not fix the issue, most likely the registry key is not getting created properly. Attached (at the bottom of this KB article) are 3 zip files, identified by the version of the Solver application you have installed and the Office version installed.
Note: The below steps require administrative permissions on the Computer
- Make sure Excel is closed
- Download the appropriate zip file
- Extract its content
- Double Click the .reg file.
- 2 or 3 prompts may appear on your computer
- Prompt 1: Provide credentials to your computer
- Prompt 2: Approve the execution of the .reg file on your computer
- Prompt 3: Successful completion of the registry update
After completing the steps, launch the report and it should load properly.
- Save to Desktop
- Double-click to update the Registry
This change allows you to use OSR functions in Excel.
Properties:
Applies to
Report Designer
Cloud
Private Host 5x
BI360 4x