Summary:
This article troubleshoots an issue where Report Publisher jobs fail when not logged in as an Admin. Normally, Report Publisher allows users to log into the application as either Windows Authentication or the Admin account. When user logs in as Windows Authentication and schedules a job to email or to folder, the job fails if the user logs off from the computer where Publisher is installed.
Symptoms:
When a user schedules a Report Publisher job, it fails when logged in as Windows Authentication to Report Publisher. When logged in as the Admin account, it works fine.
Causes:
It can be caused by many things. Please verify the steps in Resolution section to ensure the environment is setup properly for Report Publisher to run successfully.
Resolution:
Following are steps that needs to be verified to ensure the environment is setup properly.
- Ensure the folder call "Desktop" is created with read/write access at:
C:\Windows\SysWOW64\config\systemprofile AND C:\Windows\System32\config\systemprofile - Ensure the Report Publisher job in task scheduler is running has the "Run with highest privileges" checkmarked.
- Ensure the parameters in a subscription are not left blank.
- If none of the steps above work, delete the subscription and recreate it.
Properties:
Report Publisher 3.x and higher