Summary:
This article troubleshoots an error that can occur when loading a report in Excel using Cloud or Private Host.
Symptoms:
There are a few variations of this error that can be resolved with the same troubleshooting steps.
When a user loads a report in Excel, they receive the following error message:
Authentication failed. Please try again.
Base URL: https://cloud.bi360.com/Request URL: /api/portal/launcher/authenticate
Another instance of this error could be the following:
System.Exception: Authentication failed. Please try again. at Toolkit.Web.ASPNETSessionAuthenticator.Authenticate(IRestClient client, IRestRequest request) at RestSharp.RestClient.AuthenticateIfNeeded(RestClient client, IRestRequest request) at RestSharp.RestClient.Execute(IRestRequest request, String httpMethod, Func`3 getResponse) at RestSharp.RestClient.Execute(IRestRequest request) at DesktopLauncher.ReportLauncher.DownloadFile() at DesktopLauncher.ReportLauncher.Open() at DesktopLauncher.Program.LaunchReport(String url) at DesktopLauncher.Program.<>c__DisplayClass0_0. b__0(Object sender, DoWorkEventArgs doWorkArgs)
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OSR Version: 5.x
Authentication failed. Please try again. Base URL: http://solver.local/Request URL: / [...]
Error Message: The remote name could not be resolved: 'solver.local'[...]"
In some instances, users who experience variations of the error above are still able to create New templates and launch Excel.
Causes:
The error message mentions System.Net.TlsStream.CallProcessAuthentication. There are two possible reasons for this error.
- The wrong TLS version. You will need tls-version 1.2 and if you are running Win7, you need to explicitly direct a setting in the registry to use TLS 1.2 for the server.
- The proxy or firewall is used and blocking requests.
Resolution:
- In Excel, Click OK on the error and go to BI360/Solver Reporting tab in Excel Options.
- Ensure that the correct URL is set on Private Host or Cloud portal by going to Setting > System settings > General > Portal URL within the Web Portal. Make sure this URL matches the portal URL you are browsing to.
Additionally, ensure that the correct URL is set on Private Host Portal by going to Settings >System Settings > General Portal URL within the Web Portal. Make sure this URL matches with the portal URL you are browsing to. - In some instances, you will want to review the site bindings to ensure they are correct. Please refer to Making-the-BI360-Portal-Accessible-outside-the-web-server.
- After reviewing site bindings and/or making necessary changes, reboot the machine, then try editing a report again.
- If you are running Windows 7, see the attached TLS registry file.
- Download attached Zip File
- Click the TLS registry file
- Test to confirm that the error does not occur.
A workaround solution: while having a new template open in Excel, the user can select Edit on an existing report template and the error should not occur.
- Verify your SSL certificate is current
- Confirm the report is saved as a temp file or saved in a local file path. The report should display a file location similar to the following, if using the temp file location.
Example: C: >>Users>>>Username>>AppData>>>Local >>>Temp >>>OSR >>> C4834xxxxxxxxxxxxxxxxxxx
Note: If the report has been saved using Save As and placed in a OneDrive location it will lose its path to properly authenticate the user.
If the report has been saved using a OneDrive path you will need to open the report save as a temp file or local file. Please visit the following Knowledgebase article for more details: Cloud: Saving a cloud report from default to new location
Properties:
Solver Cloud
Private Host