Summary:
When attempting to connect to BI360 Reporting in Excel, the user receives the following error:
Symptoms:
Unable to connect to Repository. Please check your connection settings.
OneStop.Framework.Repository.RepositoryException: Unable to connect to Repository. Please check your connection settings. --- System.Data.SqlClient.SqlException: A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The wait operation timed out.) --- System.ComponentModel.Win32Exception: The wait operation timed out --- End of inner exception stack trace --- at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.ConsumePreLoginHandshake(Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, Boolean......
Cause:
This error may look familiar at first but the keyword is in the bold part. It states the application is able to establish a connection to the server but an error occurred during the pre-login handshake. The user has verified they can ping to the SQL server where the OSR_Repository is located from the local machine, and the anti-virus is not blocking the connection.
Resolution:
Installing the latest version of .NET Framework available should resolve this issue.
References:
Properties:
Applies To:
- BI360 Reporting 4.x
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