Summary:
This article troubleshoots an error that occurs when connecting to BI360 Report Designer or Player whose server has lost its IP address.
Symptoms:
When a user connects to BI360 Designer or Player, they receive the following error message:
There was a problem loading the System Integration Package for this Report.
System.AggregateException: One or more errors occurred. --- System.AggregateException: One or more errors occurred. --- System.InvalidOperationException: Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached.
at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource`1 retry)
at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry)
at System.Data.SqlClient.SqlConnection.Open()
at OneStop.Toolkit.Data.DatabaseConnection.Open() in e:\Builds\4\Champagne\v4.5 - OSR Installer\Sources\Source\Toolkit\Toolkit.Data\Abstract\DatabaseConnection.cs:line 102
at OneStop.Toolkit.Data.DatabaseConnection.AutoClose(MethodInvoker method) in e:\Builds\4\Champagne\v4.5 - OSR Installer\Sources\Source\Toolkit\Toolkit.Data\Abstract\DatabaseConnection.cs:line 597
at OneStop.Toolkit.Data.DatabaseConnection.ExecuteScalar(IDbCommand cmd, IEnumerable`1 parameters) in e:\Builds\4\Champagne\v4.5 - OSR Installer\Sources\Source\Toolkit\Toolkit.Data\Abstract\DatabaseConnection.cs:line 298
at OneStop.Framework.Engine.Integration.DatabaseDimSegBuilder.GetQueryResult(QueryInfo query, Boolean returnTable) in e:\Builds\4\Champagne\v4.5 - OSR Installer\Sources\Source\Foundation\Framework.Engine\Integration\DatabaseDimSegBuilder.cs:line 161
at OneStop.Framework.Engine.Integration.DatabaseDimSegBuilder.CheckQuery(QueryInfo query) in e:\Builds\4\Champagne\v4.5 - OSR Installer\Sources\Source\Foundation\Framework.Engine\Integration\DatabaseDimSegBuilder.cs:line 136
at OneStop.Framework.Engine.Integration.DatabaseDimSegBuilder.
Causes:
This is due to the server that the Report is running off of losing its IP address.
Resolution:
Manually register the IP address again and it should be able to connect.
Properties:
Report Designer 4x